PlayOn – a worthy attempt, but I think I’ll be MovingOn

It’s been a few months since dropping our cable TV service in lieu of cheaper alternatives. The solution I came up with is a combination of over the air digital TV stations, Netflix streaming, and a piece of software called PlayOn that would allow me to stream Hulu (and a handful of other content providers) from a PC to my PS3 and Xbox 360 game consoles.

Well, we’ve survived so far, but it has been a bit frustrating at times. Picking up digital TV stations over the antenna has been pretty solid; only a few times during really bad weather that I’ve had any issues. Using Netflix has also been pretty solid when using the PS3 and the Netflix provided CD to stream video – I’m actually really impressed with the video quality so far.

That leads me to the last of the bunch – PlayOn. My first month or so of using PlayOn was great. I was able to watch Hulu using my PS3 and Xbox…and even stream Netflix to my Xbox without needing to have an Xbox Gold membership. I should have known it was too good to be true.

I ran through the 14-day trial period and decided to buy a license for PlayOn. It continued to work great for about 2 more weeks…and then all of the sudden…I had issues connecting to Hulu. That seemed to get resolved after a few days; however, it hasn’t been the same since. I’ve had nothing but problems with video lag, stuttering, hanging, audio and video being out of sync. To PlayOn’s credit, they seem to be releasing updates/patches to try to keep up with all of the bugs – I’ve had the “luxury” of downloading and installing at least 5 PlayOn updates/patches since installing the software a little over 2 months ago.

I’ve worked with their support staff for a couple of days trying to resolve the issue. Unfortunately,
I’ve pretty much lost hope after the last contact from their support said the following:

“This is often indicative of something such as Security or AntiVirus software killing the stream. That’s almost certainly what is going on here.”

I had already told them that I had uninstalled my anti-virus to eliminate that as the culprit – and I wasn’t running a software firewall; yes, I have an external firewall, but no changes have been made to it – AND let’s not forget, PlayOn did work fine initially for the first month or so.

So, I’m pretty chalking up PlayOn as a loss. Of course, your mileage may vary. I just don’t have the time or patience anymore. It has to be quite a challenge for the PlayOn developer staff to stay on top of all of the changes that the various video content providers make.

I’m thinking my best bet is to look at getting a small PC or Mac Mini to hook up directly to my TV, maybe slap a digital tuner in it, and call it good. I guess that would solve my DVR issue too!